Naar hoofdinhoud
MijnOverheid

Geschikte browsers

Om veilig gebruik te maken van MijnOverheid moet u gebruik maken van een geschikte browser. Zorg er ook voor dat uw browser voorzien is van de laatste updates. Alleen dan kunt u veilig gebruik maken van MijnOverheid.

MijnOverheid adviseert gebruik te maken van 1 van de onderstaande browsers.

  • Chrome
  • Edge
  • Safari (Alleen Apple)
  • Mozilla Firefox
  • Opera

Let op! Internet Explorer wordt niet meer ondersteund. Wanneer u Internet Explorer gebruikt kunt u niet meer volledig gebruik maken van MijnOverheid.

Kijk voor meer informatie over geschikte browsers op veiliginternetten.nl (hoe update ik mijn browser) Kijk voor meer tips over veilig gebruik maken van MijnOverheid op MijnOverheid/Veiligheid